issue with opal 3.5.2 finding ptlib 2.5.2

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

issue with opal 3.5.2 finding ptlib 2.5.2

Peter Robinson
Hi All,

I think I'm going mad. I'm trying to build the ekiga 3.1.0 build to
push to rawhide but I'm running into another build issue. Nothing else
has changed in the build env except the versions and ptlib with devel
libraries are installed. Ideas anyone?

Peter

configure: gcc version is 4.3.2
checking if gcc version is valid... yes
checking for working bit scan intrinsic... yes
configure: Opal version is 3.5.2
checking where plugins are being installed... /usr/lib64/opal-3.5.2
checking wether to build a shared library... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-redhat-linux-gnu
checking Debugging support... no
checking for PTLIB... yes
Version:  2.5.2
CFLAGS:   -DPTRACING=1 -D_REENTRANT -D_GNU_SOURCE=1 -fno-exceptions
-I/usr/kerberos/include -I/usr/include/SDL
CXXFLAGS: -felide-constructors -Wreorder
DEBUG:    -L/usr/kerberos/lib64 -lpt_d -lssl -lcrypto -lz -lSDL
-lpthread -lresolv -ldl
RELEASE:  -L/usr/kerberos/lib64 -lpt -lssl -lcrypto -lz -lSDL
-lpthread -lresolv -ldl
checking ptlib version... 2.5.2
configure: error: Could not find a linkable ptlib in specified
environment to verify symbols (debug ptlib: no)
error: Bad exit status from /var/tmp/rpm-tmp.SnlcOY (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.SnlcOY (%build)
_______________________________________________
Ekiga-devel-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/ekiga-devel-list
Reply | Threaded
Open this post in threaded view
|

Re: issue with opal 3.5.2 finding ptlib 2.5.2

Damien Sandras
Hi Peter,

Le mardi 06 janvier 2009 à 05:50 +0100, Peter Robinson a écrit :

> Hi All,
>
> I think I'm going mad. I'm trying to build the ekiga 3.1.0 build to
> push to rawhide but I'm running into another build issue. Nothing else
> has changed in the build env except the versions and ptlib with devel
> libraries are installed. Ideas anyone?
>
> Peter
>
> configure: gcc version is 4.3.2
> checking if gcc version is valid... yes
> checking for working bit scan intrinsic... yes
> configure: Opal version is 3.5.2
> checking where plugins are being installed... /usr/lib64/opal-3.5.2
> checking wether to build a shared library... yes
> checking build system type... x86_64-unknown-linux-gnu
> checking host system type... x86_64-unknown-linux-gnu
> checking target system type... x86_64-redhat-linux-gnu
> checking Debugging support... no
> checking for PTLIB... yes
> Version:  2.5.2
> CFLAGS:   -DPTRACING=1 -D_REENTRANT -D_GNU_SOURCE=1 -fno-exceptions
> -I/usr/kerberos/include -I/usr/include/SDL
> CXXFLAGS: -felide-constructors -Wreorder
> DEBUG:    -L/usr/kerberos/lib64 -lpt_d -lssl -lcrypto -lz -lSDL
> -lpthread -lresolv -ldl
> RELEASE:  -L/usr/kerberos/lib64 -lpt -lssl -lcrypto -lz -lSDL
> -lpthread -lresolv -ldl
> checking ptlib version... 2.5.2
> configure: error: Could not find a linkable ptlib in specified

It seems it does not find libpt.so at all...
--
 _     Damien Sandras
(o-      
//\    Ekiga Softphone : http://www.ekiga.org/
v_/_   Be IP           : http://www.beip.be/
       FOSDEM          : http://www.fosdem.org/
       SIP Phone       : sip:[hidden email]
                       

_______________________________________________
Ekiga-devel-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/ekiga-devel-list
Reply | Threaded
Open this post in threaded view
|

Re: issue with opal 3.5.2 finding ptlib 2.5.2

Craig Southeren
Damien Sandras wrote:
> Hi Peter,
>
> Le mardi 06 janvier 2009 à 05:50 +0100, Peter Robinson a écrit :
>> Hi All,
>>
>> I think I'm going mad. I'm trying to build the ekiga 3.1.0 build to
>> push to rawhide but I'm running into another build issue. Nothing else
>> has changed in the build env except the versions and ptlib with devel
>> libraries are installed. Ideas anyone?

..deleted

If you build ptlib with debugging (i.e. ./configure --enable-debug),
then you must also compile opal with debugging (i.e. ,.configure
--enable-debug)

Also, if you do not have PTLIBDR set when compiling PTLIB and Opal, then
you must install PTLib else Opal will not be able to find it.

   Craig


-----------------------------------------------------------------------
  Craig Southeren          Post Increment – VoIP Consulting and Software
  [hidden email]                   www.postincrement.com.au

  Phone:  +61 243654666      ICQ: #86852844
  Fax:    +61 243656905      MSN: [hidden email]
  Mobile: +61 417231046      Jabber: [hidden email]

  "Science is the poetry of reality." Richard Dawkins
_______________________________________________
Ekiga-devel-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/ekiga-devel-list
Reply | Threaded
Open this post in threaded view
|

Re: issue with opal 3.5.2 finding ptlib 2.5.2

Peter Robinson
>> Hi Peter,
>>
>> Le mardi 06 janvier 2009 à 05:50 +0100, Peter Robinson a écrit :
>>>
>>> Hi All,
>>>
>>> I think I'm going mad. I'm trying to build the ekiga 3.1.0 build to
>>> push to rawhide but I'm running into another build issue. Nothing else
>>> has changed in the build env except the versions and ptlib with devel
>>> libraries are installed. Ideas anyone?
>
> ..deleted
>
> If you build ptlib with debugging (i.e. ./configure --enable-debug), then
> you must also compile opal with debugging (i.e. ,.configure --enable-debug)

I don't/didn't build ptlib with debug. The configure line I used is:
./configure --prefix=/usr --disable-static --enable-opal
--enable-plugins --disable-oss --enable-v4l2 --disable-avc
--disable-v4l

> Also, if you do not have PTLIBDR set when compiling PTLIB and Opal, then you
> must install PTLib else Opal will not be able to find it.

It is installed. The rpm is installed along with the rpm with the
development include libraries installed. This worked perfectly with
ptlib-2.4.2/opal-3.4.2. Literally the only thing I've changed in the
rpm spec file (the rules file used to build the package) is the
version number so that it build using the new version.

Peter
_______________________________________________
Ekiga-devel-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/ekiga-devel-list
Reply | Threaded
Open this post in threaded view
|

Re: issue with opal 3.5.2 finding ptlib 2.5.2

Peter Robinson
In reply to this post by Craig Southeren
>>> I think I'm going mad. I'm trying to build the ekiga 3.1.0 build to
>>> push to rawhide but I'm running into another build issue. Nothing else
>>> has changed in the build env except the versions and ptlib with devel
>>> libraries are installed. Ideas anyone?
>
> ..deleted
>
> If you build ptlib with debugging (i.e. ./configure --enable-debug), then
> you must also compile opal with debugging (i.e. ,.configure --enable-debug)
>
> Also, if you do not have PTLIBDR set when compiling PTLIB and Opal, then you
> must install PTLib else Opal will not be able to find it.

You can see the complete Fedora build system logs here:
ptlib-2.5.2: http://koji.fedoraproject.org/koji/getfile?taskID=1034429&name=build.log
opal-3.5.2: http://koji.fedoraproject.org/koji/getfile?taskID=1034536&name=build.log

Peter
_______________________________________________
Ekiga-devel-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/ekiga-devel-list
Reply | Threaded
Open this post in threaded view
|

Re: issue with opal 3.5.2 finding ptlib 2.5.2

Peter Robinson
In reply to this post by Craig Southeren
>>> Hi All,
>>>
>>> I think I'm going mad. I'm trying to build the ekiga 3.1.0 build to
>>> push to rawhide but I'm running into another build issue. Nothing else
>>> has changed in the build env except the versions and ptlib with devel
>>> libraries are installed. Ideas anyone?
>
> ..deleted
>
> If you build ptlib with debugging (i.e. ./configure --enable-debug), then
> you must also compile opal with debugging (i.e. ,.configure --enable-debug)
>
> Also, if you do not have PTLIBDR set when compiling PTLIB and Opal, then you
> must install PTLib else Opal will not be able to find it.

Recompiling opal and ptlib dozens of times too many with different
configure options to see if there's one option that makes it shit
itself it turns out that the option that kills opal from actually
detecting the correct ptlib is ironically --enable-opal. Without that
opal will detect the installed ptlib and compile correctly. Is this
option now dead but hasn't been documented as such or is there some
other issue?

Peter
_______________________________________________
Ekiga-devel-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/ekiga-devel-list
Reply | Threaded
Open this post in threaded view
|

Re: issue with opal 3.5.2 finding ptlib 2.5.2

Eugen Dedu
Peter Robinson wrote:

>>>> Hi All,
>>>>
>>>> I think I'm going mad. I'm trying to build the ekiga 3.1.0 build to
>>>> push to rawhide but I'm running into another build issue. Nothing else
>>>> has changed in the build env except the versions and ptlib with devel
>>>> libraries are installed. Ideas anyone?
>> ..deleted
>>
>> If you build ptlib with debugging (i.e. ./configure --enable-debug), then
>> you must also compile opal with debugging (i.e. ,.configure --enable-debug)
>>
>> Also, if you do not have PTLIBDR set when compiling PTLIB and Opal, then you
>> must install PTLib else Opal will not be able to find it.
>
> Recompiling opal and ptlib dozens of times too many with different
> configure options to see if there's one option that makes it shit
> itself it turns out that the option that kills opal from actually
> detecting the correct ptlib is ironically --enable-opal. Without that
> opal will detect the installed ptlib and compile correctly. Is this
> option now dead but hasn't been documented as such or is there some
> other issue?

I do not use --enable-opal for building.

If I understand correctly, opal cannot find ptlib.pc, is that right?  In
that case, this should not be complicated to fix (why a file is not
found)...

--
Eugen
_______________________________________________
Ekiga-devel-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/ekiga-devel-list
Reply | Threaded
Open this post in threaded view
|

Re: issue with opal 3.5.2 finding ptlib 2.5.2

Peter Robinson
>> Recompiling opal and ptlib dozens of times too many with different
>> configure options to see if there's one option that makes it shit
>> itself it turns out that the option that kills opal from actually
>> detecting the correct ptlib is ironically --enable-opal. Without that
>> opal will detect the installed ptlib and compile correctly. Is this
>> option now dead but hasn't been documented as such or is there some
>> other issue?
>
> I do not use --enable-opal for building.
>
> If I understand correctly, opal cannot find ptlib.pc, is that right?  In
> that case, this should not be complicated to fix (why a file is not
> found)...

No, it finds ptlib.pc just fine and it identifies the version even, it
just doesn't like what it sees.

Peter
_______________________________________________
Ekiga-devel-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/ekiga-devel-list
Reply | Threaded
Open this post in threaded view
|

Re: issue with opal 3.5.2 finding ptlib 2.5.2

Peter Robinson
In reply to this post by Craig Southeren
>> Le mardi 06 janvier 2009 à 05:50 +0100, Peter Robinson a écrit :
>>>
>>> Hi All,
>>>
>>> I think I'm going mad. I'm trying to build the ekiga 3.1.0 build to
>>> push to rawhide but I'm running into another build issue. Nothing else
>>> has changed in the build env except the versions and ptlib with devel
>>> libraries are installed. Ideas anyone?
>
> ..deleted
>
> If you build ptlib with debugging (i.e. ./configure --enable-debug), then
> you must also compile opal with debugging (i.e. ,.configure --enable-debug)
>
> Also, if you do not have PTLIBDR set when compiling PTLIB and Opal, then you
> must install PTLib else Opal will not be able to find it.

This bug report is the same issue that I'm seeing.

https://sourceforge.net/tracker/index.php?func=detail&aid=2491060&group_id=204472&atid=989748
_______________________________________________
Ekiga-devel-list mailing list
[hidden email]
http://mail.gnome.org/mailman/listinfo/ekiga-devel-list