configure error

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

configure error

Pedro Albuquerque
Hi,

New user, trying to install ekiga-4.0.1 from sources on Ubuntu 14.04, core Duo, 1 GB ram, 32 bit system.

I'm getting this error:

checking for GTK... yes
checking for GLIB... yes
checking for boostlib >= 1.34... yes
checking whether the Boost::Signals library is available... yes
configure: error: Could not find a version of the library!

Can somone help me, please?

Regards,
Pedro.


_______________________________________________
ekiga-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/ekiga-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: configure error

Eugen Dedu-2
On 10/04/16 10:04, Pedro Albuquerque wrote:

> Hi,
>
> New user, trying to install ekiga-4.0.1 from sources on Ubuntu 14.04,
> core Duo, 1 GB ram, 32 bit system.
>
> I'm getting this error:
>
> checking for GTK... yes
> checking for GLIB... yes
> checking for boostlib >= 1.34... yes
> checking whether the Boost::Signals library is available... yes
> configure: error: Could not find a version of the library!

Hi Pedro,

This is because boost has not had a reliable check for its libraries.
To solve it, look at the m4 directory of ekiga.  The file
ax_boost_signals.m4 needs to be updated to a new version.  Take the new
version from
http://git.savannah.gnu.org/gitweb/?p=autoconf-archive.git;a=blob_plain;f=m4/ax_boost_signals.m4;hb=5da17fc1eedffcfadc2a7bfbb406bdc177663882 
and overwrite it in m4 directory.  Tell us if this works (it should).

--
Eugen
_______________________________________________
ekiga-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/ekiga-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: configure error

Pedro Albuquerque
Hi Eugen,

no, it didn't work, I get the same error.

Thanks,
Pedro.


Ter, 2016-04-12 às 14:41 +0200, Eugen Dedu escreveu:
On 10/04/16 10:04, Pedro Albuquerque wrote:
> Hi,
>
> New user, trying to install ekiga-4.0.1 from sources on Ubuntu 14.04,
> core Duo, 1 GB ram, 32 bit system.
>
> I'm getting this error:
>
> checking for GTK... yes
> checking for GLIB... yes
> checking for boostlib >= 1.34... yes
> checking whether the Boost::Signals library is available... yes
> configure: error: Could not find a version of the library!

Hi Pedro,

This is because boost has not had a reliable check for its libraries. 
To solve it, look at the m4 directory of ekiga.  The file 
ax_boost_signals.m4 needs to be updated to a new version.  Take the new 
version from 
http://git.savannah.gnu.org/gitweb/?p=autoconf-archive.git;a=blob_plain;f=m4/ax_boost_signals.m4;hb=5da17fc1eedffcfadc2a7bfbb406bdc177663882 
and overwrite it in m4 directory.  Tell us if this works (it should).


_______________________________________________
ekiga-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/ekiga-list
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: configure error

Eugen Dedu-2
Hi,

Taking into account that m4 file is a bit tricky.  After updating it,
what have you run: ./configure?  You must regenerate it using aclocal,
autoconf...

On 12/04/16 15:19, Pedro Albuquerque wrote:

> Hi Eugen,
>
> no, it didn't work, I get the same error.
>
> Thanks,
> Pedro.
>
>
> Ter, 2016-04-12 às 14:41 +0200, Eugen Dedu escreveu:
>
>> On 10/04/16 10:04, Pedro Albuquerque wrote:
>>> Hi,
>>>
>>> New user, trying to install ekiga-4.0.1 from sources on Ubuntu 14.04,
>>> core Duo, 1 GB ram, 32 bit system.
>>>
>>> I'm getting this error:
>>>
>>> checking for GTK... yes
>>> checking for GLIB... yes
>>> checking for boostlib >= 1.34... yes
>>> checking whether the Boost::Signals library is available... yes
>>> configure: error: Could not find a version of the library!
>>
>> Hi Pedro,
>>
>> This is because boost has not had a reliable check for its libraries.
>> To solve it, look at the m4 directory of ekiga.  The file
>> ax_boost_signals.m4 needs to be updated to a new version.  Take the new
>> version from
>> http://git.savannah.gnu.org/gitweb/?p=autoconf-archive.git;a=blob_plain;f=m4/ax_boost_signals.m4;hb=5da17fc1eedffcfadc2a7bfbb406bdc177663882
>> and overwrite it in m4 directory.  Tell us if this works (it should).
>>
>
>
>
> _______________________________________________
> ekiga-list mailing list
> [hidden email]
> https://mail.gnome.org/mailman/listinfo/ekiga-list
>

_______________________________________________
ekiga-list mailing list
[hidden email]
https://mail.gnome.org/mailman/listinfo/ekiga-list
PL
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: configure error

PL
This post has NOT been accepted by the mailing list yet.
Hi,

I am new to Ekiga, trying to compile Ekiga 4.0.1 on Ubuntu 14.04; I got the same error, please let me know how to solve this problem.  I have replaced "ax_boost_signals.m4" file with the one pointed by the link and then regenerated "configure" file using aclocal and autoconf.  But still facing the same problem.
Loading...